Can't generate workspace

Added by Scott Graham about 11 years ago


I tried using to generate a test project, and then put the of jamplus into the same directory as the jamplus test data was generated. (I also tried 0.2).

When I do:

JamToWorkspace.bat -gen=vs2008 -compiler=vs2008 Jamfile.jam build

I get a build directory, but there's no vcproj/sln in build, just some batch files and a TargetInfo subdir. I tried printing out "Workspaces" in function BuildProject() of JamToWorkspace.lua, but it's empty for reasons which aren't clear to me.

Anyone have any hints?


Replies (2)

RE: Can't generate workspace - Added by Joshua Jensen about 11 years ago

The behavior you saw is correct, but the JamToWorkspace script should warn that it has nothing to create. What the script does is identify all executables created by the Jamfile chain. It writes out a Visual Studio solution for each executable found. For projects not directly referenced by executables, they simply won't show up in the generated solution. .vcproj files will also not be written.

Nonetheless, it is possible to make the non-dependent projects available in the solution by using the Workspace rule. I have uploaded a new to ExampleProjects with the proper Workspace fix in the generator. I apologize for it being missing before.

A further example of custom workspaces is available at source:samples/projects/Jamfile.jam

Take care.


RE: Can't generate workspace - Added by Scott Graham about 11 years ago

Ah ha, that was what I was missing.

Thanks, the generate_libs works as "expected" now.