Bug #32

" in MS VisualStudio 2008 project generation

Added by Alexej Lvov almost 7 years ago. Updated almost 7 years ago.

Status:NewStart date:10/19/2010
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:JamToWorkspace
Target version:-

Description

while generating workspaces for MSVS 2008 in .dsp files appears lines like:

...
BuildCommandLine="<build directory>\jam.bat "-C<build directory>" -sPLATFORM=win32 -sCONFIG=debug <targetName>"
...

this leads to ignoring of last argument <targetName> and building of "all" target.

this issue solves by removing " symbols.

History

#1 Updated by Alexej Lvov almost 7 years ago

sorry for this. everything is fine with quotes.

it was just because of the only C.Application target in workspace is not using as default target in !BuildWorkspace and that is why the "all" target builds.

#2 Updated by Joshua Jensen almost 7 years ago

Is there a problem to be fixed here? Do you have an alternate suggestion for how things should work?

Thanks for taking the time to add the issue.

#3 Updated by Alexej Lvov almost 7 years ago

It's just a little bit confusing to have in some solution generated for a little library test !BuildWorkspace project, which builds everithing.
It seems to be not very intuitive for me to build all targets when launching someLittleTest.sln and using build command.
But i really don't think you have an issue here :) sorry for this "noise".

Thank you very much for you efforts! This project is really simple and usefull solution for startups. It's very helpful!

Also available in: Atom PDF